Exporting a view

Exporting Views in Analytics Plus

Exporting a Report in Analytics Plus

Formats

ManageEngine Analytics Plus allows you to export tables and reports in a few simple steps. You can export tables/reports in various file formats such as,

  • CSV - Exports the underlying data of a report as a Comma Separated Value (CSV) file.

  • Excel - Exports the underlying data of a report as an Excel file.

  • PDF - Exports the report as a printer-friendly Portable Document Format (PDF) file.

  • HTML - Exports the report as HTML file.

  • Image - Exports the chart as a JPG or PNG image. (applicable only for charts)

Exporting a Report as a CSV file

  • Open the report that you want to export.

  • Click on the "Export" icon present on top of the report > Export this View > As CSV. This option exports the underlying data of a report/table as a Comma Separated Value (CSV) file.

  • The Export as CSV: Settings window opens.

export-as-csv

  • File Name is selected by default and it specifies the name of the file that is to be exported.

  • In the "Export the" dropdown menu you can select the options to specify how the data is to be exported. Available options are:Choose the Column Separator for the exported file, from the column seperator drop down. Available options are Comma (,), Tab, Semicolon (;), Space and Pipe (I). By default Comma will be selected.

    • Current View (Data): This option is applicable for Tables, Charts, Pivot, Tabular View and Summary View.
    • Underlying Data: This option is applicable for Charts, Pivot, Tabular View and Summary View.
    • Current View (Without Formatting): This option is applicable for Pivot, Tabular View and Summary View.
  • Choose the Record Separator for the exported file. Available options are UNIX Line Feed, Windows (Carriage Returns + Line Feed) and MAC(Carriage Return). By default UNIX Line Feed will be selected.

  • Choose the Text Qualifier for the exported file. Available options are Single Quotes and Double Quotes. By default Double Quotes will be set as text qualifier.

  • Select Include Column Header to include the column header in the exported file.

  • Select Include Hidden Columns to include the hidden column in the exported file (applicable only for tables and tabular views).

  • Select Include Record ID to include the record ID in the exported file (applicable only for tables and tabular views).

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

  • Select Show User Filter Criteria to include the user filter criteria as a label in the exported file, this will be applicable only if you have applied a user filter in your report. (applicable only for chart, pivot and summary views).

  • Select Show Drill Down Flow to show the drill down path, this will be applicable only if you have set a drill down path in your report (applicable only for charts)

  • Click on "Export" to download the file.

Exporting a Report as an Excel file

  • Open the report that you want to export.

  • Click on the "Export" icon present on top of the report > Export this View > As Excel. This option exports the underlying data of a report/table as a Excel file.

  • The Export as Excel: Settings window opens.

export-as-excel

  • File Name is selected by default and it specifies the name of the file that is to be exported.

  • In "Export the' drop-down menu, you can specify how the data is to be exported. Available options are:

    • Current View (Data): This option is applicable for Tables, Charts, Pivot, Tabular View and Summary View.

    • Underlying Data: This option is applicable for Charts, Pivot, Tabular View and Summary View.

    • Current View (Without Formatting): This option is applicable for Pivot, Tabular View and Summary View.

  • Select the file extension from the Export as drop down menu. Available options are XLS and XLSX. By default, XLS will be selected.

  • Select Include Column Header to include the column header in the exported file.

  • Select Include Column Description to include the column description as comments in the corresponding column headers of the exported file (applicable only for tables and tabular views).

  • Select Include Hidden Columns to include the hidden column in the exported file (applicable only for tables and tabular views).

  • Select Include Record ID to include the record ID in the exported file (applicable only for tables and tabular views).

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

  • Select Show User Filter Criteria to include the user filter criteria as a label in the exported file. This will be applicable only if you have applied a user filter for your report. (applicable only for charts, Pivots and summary views).

  • Select Show Drill down Flow to show the drill down path. This will be applicable only if you have set a drill down path. (applicable for charts)

  • Click on "Export" to download the file.

Exporting a Report as a PDF file

  • Open the report that you want to export.

  • Click on the "Export" icon present on top of the report > Export this View > As PDF. This option exports the report/table in a PDF file format.

  • The Export as PDF: Settings window opens (as shown below).

export-as-pdf

  • File Name is selected by default and it specifies the name of the file that is to be exported.

  • Specify the Language in which you wish to export the data. Supported languages are English, European, Chinese, Japanese and Korean.

  • Specify the Paper Size for the PDF to be exported. Available options are:

    • Auto (Sized by Column count)

    • Letter (8.5" x 11)

    • Legal (8.5" x 14)

    • Tabloid (11 x 17)

    • A3

    • A4

  • When size of the PDF is set to Auto, the size will be modified to fit the content. When choosing other options, ensure that the column you are exporting can fit within the page to avoid content getting collapsed.

  • Specify the Page Orientation - Portrait or Landscape

  • Specify where you want to include the title in the exported file.

  • Specify where you want to include the description in the exported file.

  • Select Column Header to include the column headers in the exported file.

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface. 

  • Select Show User Filter Criteria to include the user filter criteria as a label in the exported file, this will be applicable only if you have applied a User Filter in your report. (applicable for charts, pivots and summary views).

  • Select Show Drill down Flow to show the flow of the drill down path. This will be applicable only if you have set a drill down path. (applicable for charts)

  • Click on "Export" to download the file.

In the Export as PDF window, you can choose Page Layout tab on the left, below Format & Options to customize the document that you will be exporting.

  • In this tab, you can specify the margin width and also further customize the header and footer of the document by selecting the following options in your Header and Footer at the left, center and right positions to suit your needs.

    • Blank – No content will be displayed in the specific position.

    • Title – Title of the report will be displayed in the specific position.

    • Date/Time – Date and time of export will be displayed in the specific position.

    • Page # - Page number will be displayed in the specific position.

    • Page # of # - Page number of total number of pages will be displayed in the specific position.

    • Custom Text – The text that you specify will be displayed in the specific position.

    • Logo – Your custom logo will be displayed in the specific position. This option will be available only when you have added a custom logo in your account (available only for paid accounts).

Note: You can print the views by exporting them into a printer friendly PDF file.

Exporting the Report as a HTML file

  • Open the report that you want to export.

  • Click on the "Export" icon present on top of the report > Export this View > As HTML. This option exports the report/table in a HTML file format.

  • The Export as HTML: Settings window opens.

export-as-html

  • File Name is selected by default and it specifies the name of the file that is to be exported.

  • In the "Export the" dropdown menu you can specify how the data is to be exported. Available options are:

    • Current View (Data): This option is applicable for Tables, Charts, Pivot, Tabular View and Summary View.

    • Underlying Data: This option is applicable for Charts, Pivot, Tabular View and Summary View.

    • Current View (Without Formatting): This option is applicable for Pivot, Tabular View and Summary View.

  • Choose the position where you wish to include the tittle.

  • Choose the position where you wish to include the description.

  • Select Include Column Header to include the column header in the exported file.

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

  • Select Include Hidden Columns to include the hidden column in the exported file (applicable for tables and tabular views).

  • Select Show User Filter Criteria to include the user filter criteria as a label in the exported file, this will be applicable only if you have applied a user filter to your report (applicable for charts, pivots and summary views).

  • Select Show Drill Down Flow to show the drill down path, this is applicable if you have set the drill down path (applicable for charts).

  • Click on "Export" to download the file.

Exporting the Chart as an Image

  • Export as Image option is available only for Charts. You can export a chart in a PNG or JPG file format.

  • Open the chart that you want to export.

  • Click on the "Export" icon present on top of the report > Export this View > As Image.

  • The Export as Image: Settings window opens.

export-as-image

  • File Name is selected by default and it specifies the name of the file that is to be exported.

  • Select the type of the image. Available options are .png and .jpg

  • Choose the position where you wish to insert the logo.

  • Select Include Title to include the title in the exported file.

  • Select Include Description to include the description.

  • Select Show User Filter Criteria to include the user filter criteria as a label in the exported file, this will be applicable only if you have applied a user filter to your report (applicable for charts, pivots and summary views).

  • Select Show Drill Down Flow to show the drill down path, this is applicable if you have set the drill down path (applicable for charts).

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

  • Specify the Image size in terms of width and height.

  • Click on "Export" to download the file.

Exporting a Dashboard

Similar to individual reports, dashboards can also be shared, exported and emailed. ManageEngine Analytics Plus allows you to export the Dashboard as a HTML zip file or as a PDF.

Export as HTML

  • Login to your ManageEngine Analytics Plus application and open the dashboard.

  • Click on the "Export" icon present on top of the dashboard > and then select "Export as HTML".

  • The "Export As HTML" settings page will open.

export-db-as-html

  • Specify a name for the exported HTML file in the File Name field.

  • Select required options to display title and description.

    • The possible options to customize the layout of title and description are: At Top, At Bottom and None (without title or description correspondingly).

  • Choose an option from Column Width Ratio drop down to make the column width uniform across the table. The drop-down lists below options:

    • Proportionate width as in the report.

    • Equal width for all columns.

    • Auto adjust based on the data.

  • Select Include Record ID to include the record ID in the exported file (applicable only for tables and tabular views).

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

  • Select Show User Filter Criteria option to add a label for any user filter applied.

  • Select Include Hidden Columns option to include the hidden columns.
  • Click Export. Your dashboard will be exported into a HTML file.

Export as PDF

ManageEngine Analytics Plus allows you to export the dashboard as PDF in two different layouts.

  • Layout as in Dashboard

  • Each Report in a New Page

Layout as in Dashboard

This option will export the dashboard in the same layout as arranged in dashboard.

Note:

  • This PDF export option is optimized for Dashboards containing charts and KPI widgets. Export may fail if it contains table styled reports, especially with huge data.

  • Click on the "Export" icon present on top of the dashboard > and select Export as PDF > Layout as in Dashboad.

  • This opens the Format and Options tab that provides options to format the exported PDF.

  • Specify the file name in the File Name field.

  • Set the paper size in the Paper Size option.

  • Set the orientation as Portrait or Landscape.

  • In the Zoom Factor in %, specify a value in percentage to scale the font size in your dashboards to fit to the page size appropriately. This could be scaled between 1 to 100%.

  • Select required options to display title and description. The possible options to customize the layout of title and description are: At Top, At Bottom and None (without title or description correspondingly).

  • Specify the column width radio for the table styles reports (pivot, summary, table etc.,) in your dashboard. Available options are:

    • Equal width for all columns - Choose this to have equal width for all columns.

    • Proportionate width as in the report - Choose this to set proportional column width based on the design of the original report.

  • Select Show User Filter Criteria option to add a label for user filter applied.

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

  • Click on the Page Layout tab towards the left, for page layout formatting options.

  • Specify the Margin (in Inches). Margin value should be between 0.0 to 1.0.

  • Click Export. Your dashboard will be exported into a PDF file with the layout as in dashboard.

Each Report in a New Page

This layout will export the dashboard in a single column layout displaying each report in a new page in the PDF.

This type provides the following benefits:

  • Supports adding a Table of Content.

  • Supports adding Header and Footer in each page.

  • Supports more file size for the exported PDF.

  • Supports displaying filter criteria applied in the dashboard level and in the reports level.

Follow the below steps to export the dashboard with each report in a new page.

  • Click Export icon present on top of the dashboard > then select Export > Export as PDF > Each Report in a New Page.

  • This opens the Export as PDF Settings page.

export-db-as-pdf

The Format and Options tab

  • This tab provides the formating options for the dashboard to be exported as a PDF.

  • Specify the file name on the File Name field.

  • Select the Language.

  • Set the paper size on the Paper Size option.

  • Set the Orientation as Portrait or Landscape.

  • Select required options to display title and description. The possible options to customize the layout of title and description are: At Top, At Bottom and None (without title or description correspondingly).

  • Select Show User Filter Criteria option to add a label for user filter applied.

  • Select Generate TOC checkbox to include a table of content of your dashboard in the exported PDF file.

  • Specify how to add KPI widgets in exported file in Include Widgets. Available options are.

    • None - Select this to exclude widget from the exported copy.

    • Each in a New Page - Display each widget in a new page.

    • Associate to Nearest Report - Display widget along with the nearest page.

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

  • Click on the Page Layout tab towards the left. This tab provides the page layout option.

  • Specify the Margin (in Inches). Margin value should be between 0.0 to 1.0

  • You can choose to add Header and Footer for this layout. There are three position (Left, Right or Center) and you can choose to display one of the following in these position.

    • Blank - Displays nothing in this position

    • Title - Displays the title of the file

    • Date Time - Displays the date and time of export

    • Page # - Displays the page number

    • Page # of # - Displays the page number out of total pages

    • Custom Text - Displays the custom text that is entered in the near by field

  • Click Export. Your dashboard will be exported into a PDF file with each report in a new page.

Exporting Multiple Views

ManageEngine Analytics Plus supports exporting multiple views together. Using this option you can export all the required views together in few steps.

To export multiple views:

  • Open the report that you wish to export

  • Select Export > Export Multiple Views

  • Select one of the four available options

  • As PDF

  • As Image (ZIP)

  • As CSV (ZIP)

  • As HTML (ZIP)

  • In the Export Settings window that opens, set the required options and reports

  • Click Export

Export as PDF

  • This option exports the reports in a printer-friendly Portable Document Format (PDF) file. The options in the Export Multiple Views as PDF: Settings window is similar to exporting a single view as a PDF.

  • You can select the reports that you wish to export by clicking the check box adjacent to the report title. The selected reports appear in the right-hand side box.

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

export-multi-pdf 

  • You can reorder the reports that are to be exported by clicking on the up or down arrow icon. You can also specify whether the table of contents should be generated for the exported file.

Export as Image

  • This option can be used to export multiple charts together. So by default when you try to use this option, only the charts available in the workspace will get listed in the dialog box. You can export the chart either in a .gif or .png file format.

  • The other options in the dialog are similar to exporting a single view as a chart. To select the views, you will have to use the check boxes adjacent to the report name, upon selection the report name appears on the right-hand side.

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

export-multi-image

  • You can reorder the reports that are to be exported by clicking on the up or down arrow icon. The charts will get exported as a single zip file.

Export as CSV

  • This option exports the underlying data of reports/tables as a Comma Separated Value (CSV) file. The options in the Export Multiple Views as CSV settings window are similar to exporting a single report as CSV. 

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface.

export-multi-csv 

  • You can select the reports that you wish to export by clicking the check box adjacent to the report title. The selected views appear on the right hand side box.

Export as HTML

  • This option exports the underlying data of reports/tables as a HTML file. The options in the Export Multiple Views as HTML settings window are similar to exporting a single report as HTML. 

  • Select Set Password to password protect the exported file. The chosen password will have to be shared with all intended recipients separately. Analytics Plus does not offer options to share your password through the application interface. 

export-multi-html

  • You can select the reports that you wish to export by clicking the check box adjacent to the report title.

  • You can change the order of the reports that are to be exported by clicking on the up or down arrow icon. You can also specify whether the table of contents should be generated for the exported file

Share this post : FacebookTwitter